Thursday, October 19, 2017

Who's Online

None


I pray in Fortran.
 

 
             
Welcome, Guest
Username: Password: Remember me

TOPIC: downloaded controller.php file doesn't work.

downloaded controller.php file doesn't work. 7 years 11 months ago #81

  • finack
  • finack's Avatar
Hello,

I was under the assumption that the controller.php file on this site had the changes already made to it. It doesn't appear to be touched to me. I tried it and it doesn't work. Both my index.php file and template.css have to be changed from 0555 to 0644 after every change made to either of those files.

I thought that the only area within that file that need to permissions change was the \"function saveTemplate()\" portion. Change the \"0555\" to \"0644\"?

The file I downloaded off this site looks like the original file. Permissions are still set to 0555 in the \"function saveTemplate()\" portion of the script.

Any ideas anyone? Just to let you know. I created my template and site from scratch. I had no need for a params.ini file so I don't have on in my templates dir. Not sure if this is causing issues or not. For fun I created a blank params.ini file on the server and it was automatically assigned permissions of 0644. But I still get the same problem even after setting all permission with the controller.php file to 0644. After I reset the permission on both the index.php and template.css file they always revert back to 0555 after making any type of edit and then save.
Yet I'm still able to edit at will. I don't get it. It almost seems like this all started happening after I applied to latest security patch from 1.5.14 to 1.5.15.

Any help is appreciated.

Thanks
The administrator has disabled public write access.
Moderators: ElectronicMother
Powered by Kunena Forum